summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLouie S <louie@example.com>2024-02-23 19:06:45 -0500
committerLouie S <louie@example.com>2024-02-23 19:06:45 -0500
commit3ef9931e59ef38d9bbf045b07a4dbab2fd52e3f5 (patch)
tree19954430eee7271c52fa81ed0bc5d62ae77615f6 /CMakeLists.txt
parente659d5be0974fab8c1cbfad4dbe9c680dfa6f374 (diff)
Implement db creation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index feec929..8fea537 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,7 @@ set(CMAKE_AUTOUIC ON)
option(USE_QT5 "Use Qt5, instead of Qt6" no)
option(USE_QT6 "Use Qt6, instead of Qt5" no)
-set(qt_components "Core" "Gui" "UiTools" "Widgets")
+set(qt_components "Core" "Gui" "Sql" "UiTools" "Widgets")
set(qt_names "Qt6" "Qt5")
if(USE_QT5)
set(qt_names "Qt5")
@@ -33,6 +33,8 @@ endforeach()
set(project_sources
"src/add_entry_form.ui"
"src/add_group_form.ui"
+ "src/backend/db_sqlite.cpp"
+ "src/backend/db_sqlite.h"
"src/assignmentList.cpp"
"src/assignmentList.h"
"src/assignmentList.ui"