summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorlouie <lshprung@tutanota.com>2024-05-13 14:17:26 -0400
committerlouie <lshprung@tutanota.com>2024-05-13 14:17:26 -0400
commit7f90ba4fd34ba79d82947d951fee4bbff56d4fc3 (patch)
tree15b5bfeb6404bd4d06c3fc3d060b486c68c3cae8 /Makefile.am
parent8ccbb6548b615e81dc6c1f39162effc36f4d844b (diff)
Add full-clean target; remove unnecessary autotools files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c15eaf..d9c21c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,3 +3,15 @@ dist_man_MANS = man
man1_MANS = man/$(PACKAGE_NAME).1
man5_MANS = man/$(PACKAGE_NAME)-config.5
EXTRA_DIST = debian
+
+# remove everything, such that autoreconf -ivf must be run again
+full-clean: maintainer-clean
+ -rm -rf aclocal.m4
+ -rm -rf compile
+ -rm -rf config.*
+ -rm -rf configure
+ -rm -rf depcomp
+ -rm -rf install-sh
+ -rm -rf Makefile.in
+ -rm -rf */Makefile.in
+ -rm -rf missing