summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLouie S <louie@example.com>2023-03-02 21:36:07 -0800
committerLouie S <louie@example.com>2023-03-02 21:36:07 -0800
commit02f7ca01c62c34b775643ca1872338af06b5a9ba (patch)
tree0cc98f70ead4210e411645fa0f50c7c612457283 /configure.ac
parente64d5d0c347c7c7155f414d8c2a7c766523ded9b (diff)
configure flag to enable/disable desktop entry installation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 22fe560..fab92d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,15 @@ esac
AM_CONDITIONAL([UNIX], [test "$build_unix" = "yes"])
AM_CONDITIONAL([WINDOWS], [test "$build_windows" = "yes"])
+# enable/disable options
+AC_ARG_ENABLE([desktop-entry],
+ [AS_HELP_STRING([--enable-desktop-entry],
+ [install a desktop entry (default is no)])],
+ [desktop_entry=$enableval],
+ [desktop_entry=no])
+
+AM_CONDITIONAL([DESKTOP_ENTRY], [test "$desktop_entry" = "yes"])
+
AC_CONFIG_FILES([Makefile
src/Makefile
docs/Makefile
@@ -56,7 +65,8 @@ cat << EOF
** Configuration summary for ${PACKAGE_NAME} ${PACKAGE_VERSION}
- Prefix: ${prefix}
- Compiler: ${CC} ${CFLAGS} ${CPPFLAGS}
- Libraries: ${LIBS}
+ Prefix: ${prefix}
+ Compiler: ${CC} ${CFLAGS} ${CPPFLAGS}
+ Libraries: ${LIBS}
+ Desktop Entry: ${desktop_entry}
EOF