summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlouie <lshprung@tutanota.com>2023-06-19 17:28:39 -0700
committerlouie <lshprung@tutanota.com>2023-06-19 17:28:39 -0700
commit5443773a4ef21ae63ab5f3632909cf253368a508 (patch)
treea95a16490131cc15bb665926698a4ef12b2deeb2 /configure.ac
parenta11237da7f7722d37c42b49e86c6ddeb85486d62 (diff)
parent5683ccf3a01d8d97b08f8ecbf656a3d92f9737ef (diff)
Merge remote-tracking branch 'origin/testing'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 78ee96c..bb8e8e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,10 +59,14 @@ AC_ARG_ENABLE([embed_icon],
[embed icon in windows executable (default is yes)])],
[embed_icon=no])
if test "x$embed_icon" = "xyes"; then
- AC_CHECK_TOOL([WINDRES], [windres])
- AS_VAR_IF([WINDRES], [],
- [AC_MSG_WARN([Cannot embed icon])
- embed_icon=no])
+ if test "x$build_windows" = "xyes"; then
+ AC_CHECK_TOOL([WINDRES], [windres])
+ AS_VAR_IF([WINDRES], [],
+ [AC_MSG_WARN([Cannot embed icon])
+ embed_icon=no])
+ else
+ embed_icon=no
+ fi
fi
AM_CONDITIONAL([EMBED_ICON], [test "$embed_icon" = "yes"])