summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLouie S <louie@example.com>2023-03-04 13:43:45 -0800
committerLouie S <louie@example.com>2023-03-04 13:43:45 -0800
commit00403d8413157e08eeaba7a1932f17c3c7b0758e (patch)
tree6f2b20ff98092bd7cbac529d64bbd31b2519b909 /configure.ac
parent712af9ea3cb3d0de866221ade19341fd114f7000 (diff)
Configure flag for disabling icon embed for windows executable
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5ffbe5f..5ddeef4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,13 +47,19 @@ AM_CONDITIONAL([WINDOWS], [test "$build_windows" = "yes"])
# enable/disable options
AC_ARG_ENABLE([desktop-entry],
- [AS_HELP_STRING([--enable-desktop-entry],
- [install a desktop entry (default is no)])],
- [desktop_entry=$enableval],
- [desktop_entry=no])
-
+ [AS_HELP_STRING([--enable-desktop-entry],
+ [install a desktop entry (default is no)])],
+ [desktop_entry=$enableval],
+ [desktop_entry=no])
AM_CONDITIONAL([DESKTOP_ENTRY], [test "$desktop_entry" = "yes"])
+embed_icon=yes
+AC_ARG_ENABLE([embed_icon],
+ [AS_HELP_STRING([--disable-embed-icon],
+ [embed icon in windows executable (default is yes)])],
+ [embed_icon=no])
+AM_CONDITIONAL([EMBED_ICON], [test "$embed_icon" = "yes"])
+
AC_CONFIG_FILES([Makefile
src/Makefile
docs/Makefile
@@ -70,4 +76,5 @@ cat << EOF
Compiler: ${CC} ${CFLAGS} ${CPPFLAGS}
Libraries: ${LIBS}
Desktop Entry: ${desktop_entry}
+ Embed Icon: ${embed_icon}
EOF