summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d958ca..78ee96c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,12 @@ AC_ARG_ENABLE([embed_icon],
[AS_HELP_STRING([--disable-embed-icon],
[embed icon in windows executable (default is yes)])],
[embed_icon=no])
+if test "x$embed_icon" = "xyes"; then
+ AC_CHECK_TOOL([WINDRES], [windres])
+ AS_VAR_IF([WINDRES], [],
+ [AC_MSG_WARN([Cannot embed icon])
+ embed_icon=no])
+fi
AM_CONDITIONAL([EMBED_ICON], [test "$embed_icon" = "yes"])
AC_CONFIG_FILES([Makefile