summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLouie S <louie@example.com>2024-03-16 17:52:01 -0400
committerLouie S <louie@example.com>2024-03-16 17:52:01 -0400
commit3a9b931e6a8c5d21fb776791cbfaad4bcdb8cc56 (patch)
tree8e89cbe0c0131a8e5d7e466ba4034bcd4b3dfc33 /CMakeLists.txt
parent84137fe7739f14c9dc5697105cf1ae2af4271b4e (diff)
Tidy up about page
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fea0dae..19fed72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ cmake_minimum_required(VERSION 3.5)
project(assignment-list VERSION 0.0.1 LANGUAGES CXX)
+set(PROJECT_TITLE "Assignment List")
+
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED)
@@ -77,9 +79,12 @@ set(project_uis
)
set(project_misc
+ "resources.qrc"
"src/icon/assignment-list.rc"
)
+configure_file(config.h.in ${CMAKE_CURRENT_SOURCE_DIR}/config.h @ONLY)
+
add_executable(assignment-list
${project_sources}
${project_headers}