summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8154800
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,32 @@
+AC_INIT([assignment-list-tui], [0.1], [lshprung@tutanota.com])
+AC_CONFIG_SRCDIR([src/group.h])
+
+AC_CONFIG_HEADERS([config.h])
+
+AM_INIT_AUTOMAKE
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+# Setting default buffer size
+bufsize=1024
+AC_ARG_ENABLE([custom-bufsize],
+ [AS_HELP_STRING([--enable-custom-bufsize],
+ [set buffer size (default is 1024)])],
+ [bufsize=$enableval])
+AC_DEFINE_UNQUOTED([BUF_LEN], [1024], ["Buffer Size"])
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+])
+
+AC_OUTPUT