summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e131279..231f66f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,5 +5,8 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
])
-AC_CHECK_HEADERS([ncurses.h], [], AC_MSG_ERROR(missing ncurses.h))
+AX_WITH_CURSES
+if test "x$ax_cv_curses" != xyes; then
+ AC_MSG_ERROR([requires an X/Open-compatible Curses library with color])
+fi
AC_OUTPUT