summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorLouie Shprung <lshprung@scu.edu>2023-02-27 14:01:15 -0800
committerLouie S <louie@example.com>2023-02-27 21:16:17 -0800
commitd83a612b499d768eba49239100212dde06d832c3 (patch)
tree3f5f15fd345d05ed72bb18d7f29a4af83c42012b /debian/rules
parentbf0172b7e6391aa1345a0e8add0b622d08e0053b (diff)
Create debian directory for building basic .deb package
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f0465d2
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+# You must remove unused comment lines for the released package.
+#export DH_VERBOSE = 1
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+%:
+ dh $@ --with autoreconf
+
+#override_dh_install:
+# dh_install --list-missing -X.la -X.pyc -X.pyo