summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLouie Shprung <lshprung@scu.edu>2023-01-07 14:37:43 -0800
committerLouie Shprung <lshprung@scu.edu>2023-01-07 14:37:43 -0800
commit3c64e633185d7065c1a72673394acef89ff4740e (patch)
tree3f7c220040eb07246a5c8d65d5de3e8820784cb0 /src/Makefile.am
parent877917a7e5ebce25a2088d3198410423d60e6768 (diff)
Use AX_WITH_CURSES in configure
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 561c767..193c517 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,6 @@
AUTOMAKE_OPTIONS = subdir-objects
-LIBS = -lncurses
-
bin_PROGRAMS = terminal_media_launcher
-
terminal_media_launcher_SOURCES = cache.c draw.c read_cfg.c group.c entry.c unix/cache.c unix/draw.c unix/read_cfg.c
-terminal_media_launcher_LDADD = $(LIBS)
+terminal_media_launcher_LDADD = @CURSES_LIBS@
+terminal_media_launcher_CPPFLAGS = @CURSES_CFLAGS@